Belgische Eid 2.5.9 packages voor Ubuntu Dapper

Wouter heeft de nieuwste versie van de Belgische eid software gepackaged voor Debian. Aangezien ik zelf Ubuntu gebruik, heb ik zijn packages met zijn hulp gerebuild voor Ubuntu Dapper. Liefhebbers kunnen ze hier downloaden en testen in afwachting van een officiële release. Alles downloaden in een directory en installeren met dpkg -i *.deb of door in Nautilus dubbel te klikken op de packages en installeren te kiezen. (in dat geval wel eerst de libs...) Interessant aan deze versie is dat het security device voor Firefox nu wel zou werken zoals het hoort en zaken zoals Tax on web nu dus ook praktisch bruikbaar worden op Debian en Ubuntu. (ik schrijf zou, want heb het zelf nog niet kunnen testen wegens geblokkeerde kaart. Nog een bezoekje aan het gemeentehuis nodig dus... *grmbl*)

Joris, een collega van mij heeft de packages ook getest met een ACR38 en bij hem werkt het wel. (net als bij mij dus). Vermoedelijk is er toch iets mis met je setup dan. Ben je zeker dat de reader gedetecteerd wordt door de PC? (dmesg tikken nadat je hem aansluit)

Je kan misschien eens proberen het Firefox security device te installeren en zien of dat meer succes heeft? (vermoedelijk niet, maar het is het proberen waard)
Om dit te installeren, moet je wel wat afwijken van de standaard handleiding op de eid site. Meer uitleg in:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=380275

Joris (not verified)

Tue, 25/07/2006 - 21:58

De packages installeerden goed, ik zie "Reading and Administration" programma ook in mijn GNOME menu, maar ik krijg een "segmentation fault" als ik beidgui probeer te starten.

Enig idee? (Ik draai Ubuntu Dapper, uiteraard).

Tiens, dat kan ik reproduceren op mijn vaste PC hier. Moet ik eens nazien, want heb die ook al werkend gehad (op laptop dan). Vreemd. Zal er morgen nog verder naar kijken. De andere tools werken wel, veronderstel ik? (bv: beid-pkcs11-tool --test)

Joris (not verified)

Tue, 25/07/2006 - 22:53

beid-pkcs11-tool --test (ik neem aan dat dat koppelteken koppelteken is ipv dash voor test) geeft:

C_SeedRandom() and C_GenerateRandom():
error: PKCS11 function C_OpenSession failed: rv = CKR_TOKEN_NOT_PRESENT (0xe0)

Aborting.

Dat koppelteken zijn eigenlijk twee koppeltekens \"--\" dus, maar Wordpress wil dat precies vervangen...
Anyway, als hij zegt dat je token niet present is, wil dat misschien zeggen dat er geen eid in je reader zit? Op de PC waar die beidgui segfault\'e, werkte het op CLI in ieder geval wel bij mij. Zal er vanavond verder naar kijken, eerst nog wat werken. :-)

Joris (not verified)

Wed, 26/07/2006 - 11:26

Ik zei "koppelteken koppelteken" :-)

Er zit wel degelijk een kaart in. Heb die getest onder Windows en daar werkt het wel, dus ik denk ook niet dat er iets aan mankeert.

Ik heb een paar weken geleden geprobeerd om de software zelf te compileren, toen kwam ik dichter bij een werkende installatie (eidgui startte bijvoorbeeld, en herkende kaartlezer, maar gaf foutmelding bij lezen van de kaart zelf).

Uitermate eigenaardig, maar het beidgui ding is met geen stokken aan de praat meer te krijgen. Is nochtans op identiek dezelfde manier gebuild als diegene die ik eerst gemaakt had om te testen, alleen zit er hier wel een juiste changelog in. Een beetje verder onderzoek samen met Wouter, lijkt er op te wijzen dat het probleem in de wxgtk libs van Ubuntu zit. Ziet er niet zo evident op te lossen uit als het dat is. Ga alles in ieder geval morgen nog eens opnieuw builden en installeren op een clean systeem om zeker te zeker dat er niks interfereert met eerdere eid dingen die ik op mijn PCs hier gedaan heb.

Ok, nieuwe build, gemaakt op een andere machine.
Kan wie de oude al geinstalleerd heeft eens
# apt-get remove libbeid* beidgui beid-tools
en eens de nieuwe installeren aub?

Hij segfault hier niet meer en ik denk dat ik het probleem gevonden heb. Als iemand anders even kan bevestigen dat ze werken, leg ik dat straks wel verder uit. :-)

Joris (not verified)

Thu, 27/07/2006 - 11:42

beidgui opent nu inderdaad. Het lezen van de kaart wil echter nog altijd niet lukken. Ik heb zonet nogmaals geverifieerd in Windows en daar leest hij dezelfde kaart zonder problemen. De error bij eid-pkcs11-tool --test is nog steeds:

C_SeedRandom() and C_GenerateRandom():
error: PKCS11 function C_OpenSession failed: rv = CKR_TOKEN_NOT_PRESENT (0xe0)

Aborting.

In de tab Options van beidgui zie ik onder de sectie Smartcard Reader een popup menu met daarin enkel 5x "OpenCT Reader (detached)", terwijl ik mij meen te herinneren dat ik daar de naam en fabrikant van mijn lezer zou moeten zien tussenstaan als hij herkend wordt.

Zou het kunnen dat ik nog iets moet installeren ivm smartcards?

Ik had die error ook toen mijn kaartlezer niet werkte. Welk type lezer heb je? Als het het standaard Zetes ACR38 ding is, moet die er inderdaad als optie bij staan in de gui. Anders is hij niet correct geinstalleerd, probeer eens te herinstalleren dan en herstart pcscd (/etc/init.d/pcscd restart).

NB: Als je kaartlezer en kaart goed werken, zou er een grafisch venstertje moeten verschijnen dat je pin vraagt bij die test.

Joris (not verified)

Thu, 27/07/2006 - 14:18

Hm. Ik heb de driver opnieuw geinstalleerd, en nu wordt mijn lezer wel herkend. beid-pkcs11-tool --test werkt naar behoren.

beidgui echter leest (satus-LED) de kaart maar toont dan "Error: Wrong Root Certificate". Wat kan ik daar aan doen?

Joris (not verified)

Thu, 27/07/2006 - 15:34

Ik begin te gaan geloven dat er toch nog iets mis moet zijn met drivers...

beid-tool -n bijvoorbeeld geeft:

X Error: BadDevice, invalid or uninitialized input device 168
Major opcode: 145
Minor opcode: 3
Resource id: 0x0
Failed to open device

Aangezien dit waarschijnlijk niet direct iets met jouw paketten te maken heeft... is er ergens een (Belgische) site waar ik kans heb om met dit soort problemen geholpen te worden?

Bij beid-tool -n heb ik ook een error, maar langs de andere kant ben ik zeker dat mijn cardreader werkt door dit:

$ beid-pkcs11-tool --test
X Error: BadDevice, invalid or uninitialized input device 168
Major opcode: 148
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 168
Major opcode: 148
Minor opcode: 3
Resource id: 0x0
Failed to open device
C_SeedRandom() and C_GenerateRandom():
seems to be OK
Digests:
all 4 digest functions seem to work
MD5: OK
SHA-1: OK
RIPEMD160: OK
Signatures (currently only RSA signatures)
testing key 0 (Authentication)
error: PKCS11 function C_SignFinal failed: rv = CKR_PIN_LOCKED (0xa4)

Aborting.

Er komt dan een pop-up die je pin vraagt en vervolgens eentje dat me zegt dat mijn kaart geblokkeerd is. (Dat klopt, dus hij leest de kaart effectief)
Ik vermoed wel dat er iets mis is met de driver of pcscd config, zal er nog wat verder naar zoeken. (Ik heb ook zo een ACR38)

Wat de wrong root certificate error betreft: die error heeft Wouter ook al in de originele Debian packages waargenomen, maar waar ze vandaan komt is nog niet duidelijk...

Btw, voor de ACR38 heb je blijkbaar "verplicht" pcscd nodig. Dus apt-get install pcscd, daarna je ACR38 driver installeren en vervolgens pcscd herstarten en dan de eid proberen.
Ik zal eens zien om die acr38 driver van Debian ook naar Ubuntu Dapper te porten, heb die momenteel van source geinstalleerd.

Joris (not verified)

Thu, 27/07/2006 - 22:10

pcscd had ik al geinstalleerd, acr38 drivers heb ik ook zelf moeten compileren.

Joris (not verified)

Thu, 27/07/2006 - 22:20

Ik heb die directories aangemaakt en 2x Optional ingesteld, maar integenstelling tot je beschrijving in bug report krijg ik nog altijd die error als ik kaart probeer te lezen. Of bevatten die directories ook nog bestanden die niet meegeinstalleerd werden bij de installatie van het pakket?

Als ik beidgui start vanaf command line krijg ik ook die BadDevice errors te zien op het moment ik de kaart lees.

Probeer eens een make uninstall van je ACR38 gecompileerd van source en delete de directory waar je het in geinstalleerd heb. Installeer daarna de 3 libacr38u packages op http://stroobant.be/eid/ .
Ik heb ze getest en het werkt in ieder geval bij mij. (ondanks het feit dat er nog "baddevice" komt, ik vermoed dat die error gewoon geen kwaad kan)

Joris (not verified)

Sat, 29/07/2006 - 15:41

Je driverpaketten installeren goed, en lezer wordt herkend na installatie ervan, maar ik krijg nog steeds wrong root certificate error, m.a.w. bedgui toont nog altijd de inhoud van mijn kaart niet.

Ik heb een nieuwere versie gepackaged, gebaseerd op Wouters 2.5.9-4. Staat in dezelfde dir te downloaden. Installeer die eens aub? Daar zijn een aantal bugs al in gefixt. (Je kan gewoon dpkg -i doen normaal, versie is hoger en hij gaat upgraden)

Er zit zeker nog één groot probleem in, namelijk:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=380145
Dat kan hopelijk gefixt worden tegen de volgende release, maar het is nog niet duidelijk wat er precies mis gaat.

Joris (not verified)

Thu, 03/08/2006 - 17:21

Na upgrade: beidgui erro:
"Error : An internal error has been detected, but the source is unknown"

Of moet ik eerst mijn computer herstarten?

Dat is vrijwel zeker gerelateerd met die bug.
Kijk eens in je options tabblad, hoe staat alles daar ingesteld?
Bij mij staat er nu dit:

Language: English

Certificate validation:
OCSP: Not used
CRL: Mandatory

Smartcardreader: ACS ACR38U 00 00

Daarmee werkt het, als ik OCSP en CRL beiden op "Not used" zet werkt het niet meer. Het is mij niet geheel duidelijk wat er precies gebeurt, maar het zit hem in de instelling van CRL voor zover ik zie, als die "Optional" of "Mandatory" is, kan ik mijn kaart lezen. Anders niet. (NB: telkens op save drukken als je iets wijzigt, het is blijkbaar ook "normaal" dat je dan nog een "Wrong root certificate" krijgt.)

Joris (not verified)

Tue, 08/08/2006 - 23:24

Yep. En Thunderbird ook. Weet je van een manier om dat in Evolution te laten werken (mails ondertekenen)?

Jan (not verified)

Fri, 11/08/2006 - 14:06

heb zopas Ubuntu 6.06 geinstalleerd. Ik heb een ACR38U en een GemPCTwin USB lezer die zonder problemen werken onder Windows. Ik zou de eID nu ook graag willen uitlezen onder Ubuntu.
Als ik "dpkg -i *.deb" uitvoer, krijg ik de melding dat libqt3-mt en libwgxtk2.6.0 en libopenct1 ontbreken...
Waar vind ik dit en hoe installeer ik het? Ik ken een beetje linux maar ben zeker geen expert. Alle hulp is welkom!

Jan (not verified)

Fri, 11/08/2006 - 15:46

Ok, ondertussen lukt het. Die 3 packages heb ik kunnen downloaden en installeren (http://packages.ubuntu.com/dapper/libs/) en dan krijg ik geen foutmeldingen meer.

eID GUI startte ook op maar bij klikken op chip kreeg ik zelfde fout als Joris (wrong root cert). In Options tabblad de CRL dan aangepast naar Mandatory en nu werkt het wel, dus de gegevens worden nu wel ingelezen en krijg ik de wrong root foutmelding niet meer.

Bovendien kan ik bij Options kiezen welke lezer ik wil gebruiken (ze worden allebei herkend en ze werken allebei).

Mooi! :-)
Om makkelijk te installeren, kan je ook volgende lijn toevoegen in /etc/apt/sources.list:
deb http://www.stroobant.be/eid /
en dan apt-get install beidgui bv.
Je gaat wel een warning krijgen omdat de packages niet ondertekend zijn:
WARNING: The following packages cannot be authenticated!
beidgui
Install these packages without verification [y/N]? Y
...

Eens er officiele Ubuntu packages zijn (vanaf de volgende release vermoedelijk), verwijder je die lijn wel beter.

Ik betwijfel of het op 5.10 gaat werken, maar je kan proberen natuurlijk. (op eigen risico uiteraard ;-)
Als het niet werkt, is de kans groot dat ze gewoon niet willen installeren wegens missende dependencies.

Upgraden naar de nieuwste Ubuntu is echter vrij pijnloos, dus misschien is het veiliger dat je eerste je systeem upgrade...

Philip (not verified)

Tue, 22/08/2006 - 11:17

Ik heb een acer travelmate 800lci met een geïntegreerde kaartlezer op pcmci van O2 micro. Ik draai momenteel ubuntu dapper drake Ik vind hier geen drivers voor, enige suggesties?
Heb ook een externe kaartlezer ACR38u, die na het installeren van jouw pakketjes werkt in beidgui.

beid-tool geeft nog steeds dezelfde fout als hierboven reeds vermeld.

beid-tool -n
Connecting to card in reader ACS ACR38U 00 00...
X Error: BadDevice, invalid or uninitialized input device 168
Major opcode: 145
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 168
Major opcode: 145
Minor opcode: 3
Resource id: 0x0
Failed to open device
Using card driver: Belpic smartcards
Card name: Belpic smartcards

Ik krijg ook de error "Wrong root certificate". Maar kan alvast gebruik maken van de kaart voor authenticatie via Firefox. Andere toepassingen moet ik nog testen.

Bedankt voor de packages!

Ik heb een Travelmate 8003 gehad op mijn vorig werk die ook zo een O2micro cardreader heeft. Heb O2micro gecontacteerd en van hen een Linux driver gekregen, dat werkte. Ik kan je die bezorgen als je wil (of contacteer hen zelf eens, misschien zetten ze die dingen dan eindelijk online...)

Die BadDevice errors zijn mi niet gerelateerd met de wrong root certificate error, heb dat ook al bij andere QT apps gezien, start bv eens k3b op de command line en je gaat hetzelfde zien.

Hello

I think I've found a work around for this issue. (I'm using Mandriva 2010)
Just allow "testcards" in beidgui.conf. You'll get a warning when accessing card with beid-gui but it's working fine.
I also can access www.taxonweb.be without problem (naturally with PKCS#11 configured in Firefox)

Greets

Philippe

[CA_certs]
# Allow testcards
allowtestroot = 1

Koen (not verified)

Mon, 18/09/2006 - 20:48

ik probeer al geruime tijd een ACR38U kaartlezer + belpic aan de praat te krijgen op een Ubuntu 6.06 (Dapper). 'k heb zowel Dapper, Dapper + pinning uit Edgy, als de .deb's van deze site geprobeerd, en een paar experimenten met pcscd ipv beidpcscd.
De enige fout die ik nu nog zie is

Starting BEID daemons: libpcsclite.so: cannot open shared object file: No such file or directory
beidpcscd libpcsclite.so: cannot open shared object file: No such file or directory
beidcrld.

Treedt op bij om 't even welke source (stroobant, dapper, edgy, ...) en ik heb geen idee waar deze melding op slaat.
beidgui start, maar in de dropdown list met kaartlezers vindt ik alleen "OpenCT reader (detached)" - geen ACR38U. Ik veronderstel dat dat is omdat (beid)pcscd niet start omwille van die "can not open ... file" error.

in /usr/lib vind ik wel een libpcsclite.so.1 en libpcsclite.so.1.0.0 maar ik weet niet of dat er iets toe doet

iemand een idee hoe ik dit oplos of in welke richting ik moet gaan zoeken ?

Sven (not verified)

Sat, 18/11/2006 - 19:10

zoek eens naar libpcsclite.so.1, en maak dan een symbolische link als libpcsclite.so niet bestaat
(ik heb die voorgebouwde pakketten nog niet getest, maar ik heb zelf wel de paketten gecompileerd gekregen op een ubuntu dapper op mijn werk)

Ik heb vandaag ook zo'n ACR38U gekregen. De boel aangesloten (Ubuntu Edgy) en de beid stuff geïnstalleerd uit de ubuntu repo, maar dat werkte niet. Daarna de pcsc-driver geïnstalleerd waarna het lichtje blijft branden als er een eID in zit, maar de boel werkt nog steeds niet.

$ beidgui
libpcsclite.so: cannot open shared object file: No such file or directory
Error: can't open /var/run/openct/status: No such file or directory

$ beid-pkcs11-tool --test
libpcsclite.so: cannot open shared object file: No such file or directory
error: Failed to load pkcs11 module
Aborting.

$ beid-tool -n
libpcsclite.so: cannot open shared object file: No such file or directory
Error: can't open /var/run/openct/status: No such file or directory

Add new comment

The content of this field is kept private and will not be shown publicly.

Filtered HTML

  • Lines and paragraphs break automatically.
  • Web page addresses and email addresses turn into links automatically.
By submitting this form, you accept the Mollom privacy policy.