Eid / Taxonweb : Linux 1 - Windows 0

Tax-on-web op Ubuntu in 30 seconden:

$ sudo apt-get install libacr38u libacr38ucontrol-dev pcscd
$ sudo apt-get install beid*

Open /usr/share/beid/beid-pkcs11-register.html in Firefox, wacht even en klik op "Install". Er verschijnt "The "Belgium Identity Card PKCS#11" module is now registered."

Cardrreader verbinden, kaart insteken, surf naar http://www.taxonweb.be/ en je kan je belastingaangifte invullen. Op die tijd heb je met Windows net de driver voor je cardreader gevonden. ;-)
Als er nu nog iemand een oplossing kon vinden voor de x86-64'ers onder ons...

JanC (not verified)

Mon, 25/06/2007 - 00:19

Of als je nog geen e-ID hebt kan je ook gewoon hun token-kaart systeem gebruiken.

(Als je de NoScript extension voor Firefox gebruikt moet je dan wel even de cross-site scripting warning negeren... ;) )

Sven (not verified)

Wed, 18/06/2008 - 12:32

De installatie via /usr/share/beid/beid-pkcs11-register.html werkt niet helemaal, er wordt verwezen naar een onbestaande module. Je moet eerst het volgende uitvoeren:

cd /usr/lib
sudo ln -s libbeidpkcs11.so.2.1.0 libbeidpkcs11.so

Daarna zal Firefox de module zonder problemen installeren... (getest met Ubuntu 7.10 en Ubuntu 8.04)

DirkTas (not verified)

Mon, 10/11/2008 - 20:28

In de versie 8.10 van Ubuntu werkt deze methode uitstekend!!

Ja maar het is nog versie 2.6.
De nieuwe versie 3.5 is niet beschikbaar voor Ibex.
Bevestiging gekregen van hun Helpdesk

Sorry, was in een foutige afdeeling van Firefox : slecht door minfin uitgelegd : zij baseren zich op een Firefox 1.x configuratie.
Toch werkt het bij mij niet : opensuse 10.2 heeft gcc-4.1 terwijl het program met gcc-4.2 gecompileerd werd.
Weet niet ofwel daar het probleem ligt, zal het checken.

POE (Linux pio… (not verified)

Sun, 31/05/2009 - 01:09

Onder UBUNTU 9.04 werkt de kaartlezer prima met zowel oude als nieuwe identiteitskaarten. Zowel 32 als 64 bit !!!
sudo apt-get install beid*
sudo ln -s libbeidpkcs11.so.2.1.0 libbeidpkcs11.so
sudo apt-get install libacr38u libacr38ucontrol-dev pcscd
apt-get autoremove

Euh wat wil je precies waar symlinken?
Bij mij werkt hij zonder symlinks op 9.04, ik heb alleen soms problemen met de oude "Unknown root certificate" bug.

Er is intussen ook source beschikbaar voor Belpic 3.5.2 en Wouter ging kijken om die Debian/Ubuntu ready te maken als ik me niet vergis.

Hello, bij mij wil het aan geen kant lukken.
Wil je mij de compleet aanleiding geven aub.
Via bronnen reageert het programma helemaal niet!
Via site van Overheid lukt het helemaal niet om het te geinstaleerd krijgen.
Als ik typ: sudo apt-get beid* geefhij een andere versie aan dat die die gedownload is, Toch versie voor Debian gekozen, ben op Janty 9.04.
Help

Frank (not verified)

Fri, 11/06/2010 - 14:21

Na deze hanleiding krijg ik bij taxonweb volgende foutmelding:
Beveiligde verbinding mislukt
> Fout tijdens het verbinden met ccff02.minfin.fgov.be.
> SSL-peer kon niet onderhandelen over een acceptabele set
beveiligingsparameters.
> (Foutcode: ssl_error_handshake_failure_alert)

Volgens de "helpdesk" van financien "ondersteunt Tax on Web enkel Redhat Linux"
Is dat zo?

Ik heb hetzelfde probleem bij Firefox, maar niet bij internet Explorer. Heeft iemand een oplossing voor Firefox?

Koenh (not verified)

Sun, 15/05/2011 - 10:20

Ik heb mijn pc geformateerd naar kubuntu 11.04 - 64 bit.

Met deze handleiding kreeg ik beid steeds onmiddellijk aan de praat, maar deze keer heb ik problemen:
wanneer ik de registerpage probeer uit te voeren, krijg ik volgende melding:
" Registration of the "Belgium Identity Card PKCS#11" module in Mozilla, Netscape or Firefox"
Voor de rest is het een wit blad...

Ik gebruik firefox 4; Zou dit het probleem kunnen zijn?
Heeft iemand een oplossing hiervoor?
Alvast bedankt.

Als ik het me goed herinner, zegt die registratiepagina ook niet veel en kan het zijn dat het daarmee werkt. Ik denk ook dat je dit mogelijk niet meer manueel moet doen met recentere versies, maar daar ben ik niet zeker van. (kan ook zijn dat het bij mij nog van een eerdere install in mijn firefox profiel zat)

RBJA (not verified)

Fri, 03/06/2011 - 00:29

Vruchteloos heb ik de hier aangegeven richtlijnen gevolg. Vorig jaar kreeg ik zonder veel problemen de lezer aan de praat nu geeft de lezer bij gebruik van de Beidgui "interne fout". En bij het inloggen op taxonweb is de gekende melding "handshake failure" zichtbaar.
Ik heb vorige versies verwijderd en de pakketjes opnieuw geïnstalleerd.
Wat is er veranderd? Ik heb een gloednieuwe identiteitskaart, het is nu LTS 10.04 ipv 9.x , en allicht is ook Firefox een dagje ouder, het is nu 3.6.17.
HELP. Ik zou dit lang WE willen benutten met het invullen van Taxonweb en niet met het zoeken naar hoe in te loggen...

't is niet gelukt in het hemelvaart-WE. :( Tot nu gewacht en rara? Jawel. Die 30 sec is haalbaar. Als ze nu bij tax on web eens de richtlijnen zouden zetten op de manier dat ze hier gepost zijn dan zou het toch voor iedereen eenvoudiger zijn... (mijn systeem: Ubuntu 10.04 LTS Firefox 3.6.17)
Na de handleiding van deze link diende ik enkel nog het Belgium Root CA2 certificaat te erkennen (Firefox-> Edit -> Preferences-> View Certificates -> Belgium Root CA2 -> Edit -> drie vinkjes zetten -> klaar!). Voila. Over enkele uren weet ik weer wat de Belgische staat mij schuldig is ;)

How to get the eid electronic card reader ACR38U working in Ubuntu 11.04 and Mozilla Firefox 6.0.2

Configuration steps in Ubuntu 11.04
____________________________________

1. install all the beid related software in Ubuntu using apt-get or aptitude or Synaptic package managers

2. Problem:
Do not try to install or configure the Belgian eid firefox plugin, because the eid plugin for Firefox does NOT work in Ubuntu 11.04!
The Firefox plugin only works in Windows!

Workaround solution: Manually set following values in Mozilla Firefox in about:config

security.ssl.allow_unrestricted_renego_everywhere__temporarily_available_pref;true
security.ssl.enable_false_start;true
security.ssl.renego_unrestricted_hosts;*.be

3. Install and activate Firefox plugin "User Agent Switcher 0.7.3" in Mozilla Firefox and set user agent to "Internet Explorer 6" to be able to access Tax-On-Web website using Ubuntu 11.04

4. Connect the eid reader to the PC (via USB) and insert the electronic card into the reader

5. Close all instances of Mozilla Firefox and then restart Mozilla Firefox. Access www.cm.be (as an example) using Mozilla Firefox. Authentication will NOT work using Google Chrome.

Hi,

For all the Belgian people struggling with getting their ACR38U eid card working in Ubuntu 16.04 LTS 64-bit...

Please try this automated procedure to get the ACR38U eid card reader working in Ubuntu 16.04 LTS 64-bit with Tax-on-web in Belgium:

https://mark911.wordpress.com/2014/01/04/how-to-get-the-eid-electronic-…

I kept the old URL for Ubuntu 14.04 LTS, but adapted the procedure for Ubuntu 16.04 LTS 64-bit.

Regards,

Mark Rijckenberg

Add new comment

The content of this field is kept private and will not be shown publicly.

Filtered HTML

  • Lines and paragraphs break automatically.
  • Web page addresses and email addresses turn into links automatically.
By submitting this form, you accept the Mollom privacy policy.